PHP Security Updates

A critical PHP release on 21 October 2026 fixes two remote code execution flaws, CVE-2026-109618 and CVE-2026-109619. If your site runs PHP, you need to patch or upgrade. We patch and upgrade PHP apps safely, with a backup and a rollback plan on every job.

Do nothing and your site/server WILL be attacked and exploited.

The scanning never stops

CVE-2026-109618 and CVE-2026-109619 are remote code execution flaws in PHP itself, with fixed releases published on 21 October 2026. Once advisory details are public, automated scanning infrastructure probes every reachable PHP site for that exact flaw — continuously, without caring how small your site is.

If your server's PHP is below the fixed version, the only variable is who finds it first: an attacker's scanner or your patch level. Every day at the old patch level widens the window.

What an exploit costs you

A successful exploit hands the attacker your application's privileges on the machine itself. For a business owner that typically means: the site and server taken down, ransomware encrypting every file and database they can reach, customer data stolen, or the box quietly rebuilt for spam and phishing that gets your domain and email blacklisted.

Recovery costs an order of magnitude more than the patch — if full recovery is possible at all.

No plugin protects you

PHP is the underlying runtime of your entire platform — plugins, themes, frameworks and apps all run on top of it, and the flaw is in that layer, below where any configuration check, update setting or security plugin can reach. Nothing you choose at the application layer changes the outcome; only the server's PHP version does.

Demand outstrips supply

You're not the only one who needs this fix: more than 20 million platforms are in the same position, and the people who can apply it are few. Our queue is strictly first-paid, first-served.

Every day you wait moves your patch behind someone who didn't.

What You Need to Do

Patch to the point release for your current PHP version: 8.5.12, 8.4.27, 8.3.36 or 8.2.35 (21 Oct 2026)
PHP 8.2 reaches end of life on 31 Dec 2026: plan an upgrade, not just a patch
PHP 8.1 and older get no upstream fixes: use your vendor's backport or upgrade
Check your PHP version and whether PHP-FPM, Apache mod_php or php-cgi is in use
Restart all PHP workers after patching so the fix takes effect

Step 1: The £149 PHP Check

An automated PHP version and configuration check, with a written report of your exposure and the recommended next step. The fee is not credited against the patch or upgrade. Plugin, module and custom code review is included in the paid upgrade.

Start with the £149 PHP Check

Want to see the deliverable first? Read a sample report, check your PHP version yourself, or see PHP end-of-life dates.

Frequently Asked Questions

Do I need to act now?+

Yes if your site runs a PHP version in the affected range. Upstream PHP released fixed versions 8.5.12, 8.4.27, 8.3.36 and 8.2.35 on 21 October 2026. PHP 8.1 and older no longer receive upstream fixes, so those need an upgrade or a vendor backport.

Is my site affected if I don't run PHP directly?+

If any part of your stack runs PHP, such as a CMS, storefront, admin panel or API, treat it as in scope. Hosts often run PHP for you, so ask them which version and patch level they run.

Will you check whether I've already been compromised?+

Patching closes the hole but doesn't prove nothing got in before. We can review logs and file changes as part of an emergency job, and we'll tell you clearly what we could and couldn't confirm.

Patch PHP Before It's Exploited

Tell us your application and PHP version. We'll confirm your exposure and give you a fixed-scope quote.